Login    Register
  • Author
    Message

Issue with composer / install process

Postby adamh » Wed Feb 25, 2015 11:19 pm

Hi all,

Very excited about trying this CMS but currently I cant even get to the installation process due to the fact that that composer wont get the dependencies it needs. I may be totally wrong as this is the first time I have used composer but it seems like a problem with the composer.json file.

I get the following error in terminal -

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install laravel/framework 4.1.x-dev
- illuminate/http 5.1.x-dev requires illuminate/support 5.1.* -> satisfiable by illuminate/support[5.1.x-dev].
- don't install illuminate/support 5.1.x-dev|install illuminate/support dev-master
- Conclusion: don't install illuminate/support dev-master
- Conclusion: don't install laravel/framework 4.2.x-dev
- Conclusion: don't install illuminate/http 5.0.x-dev
- Installation request for vespakoen/menu dev-master -> satisfiable by vespakoen/menu[dev-master].
- Installation request for laravel/framework 4.1.* -> satisfiable by laravel/framework[4.1.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.31, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
- Conclusion: don't install laravel/framework 4.0.x-dev
- Conclusion: don't install illuminate/console 5.0.x-dev|install laravel/framework 4.0.x-dev
- Conclusion: don't install laravel/framework v4.1.30|install illuminate/console 5.0.x-dev
- Installation request for creolab/laravel-modules dev-master -> satisfiable by creolab/laravel-modules[dev-master].
- Conclusion: don't install laravel/framework v4.1.31|install illuminate/console 5.0.x-dev
- Installation request for barryvdh/laravel-ide-helper dev-master -> satisfiable by barryvdh/laravel-ide-helper[dev-master].
- creolab/laravel-modules dev-master requires laravel/framework ~4 -> satisfiable by laravel/framework[4.0.x-dev, 4.1.x-dev, 4.2.x-dev, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.13, v4.1.14, v4.1.15, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.2, v4.1.20, v4.1.21, v4.1.22, v4.1.23, v4.1.24, v4.1.25, v4.1.26, v4.1.27, v4.1.28, v4.1.29, v4.1.3, v4.1.30, v4.1.31, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.0
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.1
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.10
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.11
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.12
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.13
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.14
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.15
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.16
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.17
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.18
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.19
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.2
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.20
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.21
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.22
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.23
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.24
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.25
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.26
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.27
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.28
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.29
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.3
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.4
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.5
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.6
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.7
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.8
- don't install illuminate/http v5.0.0|don't install laravel/framework v4.1.9
- vespakoen/menu dev-master requires illuminate/http 5.* -> satisfiable by illuminate/http[5.0.x-dev, 5.1.x-dev, v5.0.0, v5.0.4].
- Conclusion: don't install illuminate/http v5.0.4|install laravel/framework 4.0.x-dev|install laravel/framework v4.1.30|install laravel/framework v4.1.31


Any ideas on this would be greatly appreciated.

Many thanks

Adam
adamh
 
Posts: 1
Joined: Wed Feb 25, 2015 11:12 pm

Return to Doptor Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron